This blog I am going to have my configuration for my vyos, my edges, avn. I hope this will help if you want a vyos box instead of the cloud builder for all your networking for a standard VLC VCF deployment. Its great to have an example which you can copy from. This has been tested and working in my lab environment on VCF 4.5.2 via BGP.

I have created the following vlans on my vyos, each of these represent a interface/ethernet on the vyos box and all expect external are connected to the same port group ‘pg-vcf’ – vlan trunk config 0-4094, security on the port group are all accept.

VLAN 11 – edge uplink 1

VLAN 12 – edge uplink 2

VLAN 13 – edge tep

VLAN 8 – vSAN

VLAN 9 – vMotion

VLAN 14 – esxi host overlay tep – has dhcp as well

VLAN 10 – management

VLAN 4 – external gateway ip is the same network as my router and network of my static route destination

My vyos box has the following configuration – ip address and vlans on each interface, MTU, speed, DHCP, my bgp configuration, static route, ntp. Below are the commands I used.

delete interfaces ethernet eth0 address dhcp
set service ssh port 22

set interfaces ethernet eth0 vif 11 description 'vlan11'
set interfaces ethernet eth0 vif 11 address '172.27.11.1/24'

set interfaces ethernet eth1 vif 12 description 'vlan12'
set interfaces ethernet eth1 vif 12 address '172.27.12.1/24'

set interfaces ethernet eth2 vif 4 description 'vlan4'
set interfaces ethernet eth2 vif 4 address 'external ip same network as static route/24'

set interfaces ethernet eth3 vif 13 description 'vlan13'
set interfaces ethernet eth3 vif 13 address '172.27.13.1/24'

set interfaces ethernet eth4 vif 8 description 'vlan8'
set interfaces ethernet eth4 vif 8 address '10.0.8.253/24'

set interfaces ethernet eth5 vif 9 description 'vlan9'
set interfaces ethernet eth5 vif 9 address '10.0.4.253/24'

set interfaces ethernet eth6 vif 14 description 'vlan14'
set interfaces ethernet eth6 vif 14 address '172.16.254.1/24'

set interfaces ethernet eth7 vif 10 description 'vlan10'
set interfaces ethernet eth7 vif 10 address '10.0.0.1/24'

set interfaces ethernet eth0 mtu 9000
set interfaces ethernet eth1 mtu 9000
set interfaces ethernet eth2 mtu 9000
set interfaces ethernet eth3 mtu 9000
set interfaces ethernet eth4 mtu 9000
set interfaces ethernet eth5 mtu 9000
set interfaces ethernet eth6 mtu 9000
set interfaces ethernet eth7 mtu 9000

set interfaces ethernet eth0 duplex 'auto'
set interfaces ethernet eth0 speed 'auto'
set interfaces ethernet eth1 duplex 'auto'
set interfaces ethernet eth1 speed 'auto'
set interfaces ethernet eth2 duplex 'auto'
set interfaces ethernet eth2 speed 'auto
set interfaces ethernet eth3 duplex 'auto'
set interfaces ethernet eth3 speed 'auto'
set interfaces ethernet eth4 duplex 'auto'
set interfaces ethernet eth4 speed 'auto'
set interfaces ethernet eth5 duplex 'auto'
set interfaces ethernet eth5 speed 'auto'
set interfaces ethernet eth6 duplex 'auto'
set interfaces ethernet eth6 speed 'auto'
set interfaces ethernet eth7 duplex 'auto'
set interfaces ethernet eth7 speed 'auto'

set service dhcp-server shared-network-name DHCP_Pool_ETH6 subnet 172.16.254.0/24
set service dhcp-server shared-network-name DHCP_Pool_ETH6 authoritative enable

set service dhcp-server shared-network-name DHCP_Pool_ETH6 subnet 172.16.254.0/24 start 172.16.254.6 stop 172.16.254.254

set protocols static route 0.0.0.0/0 next-hop externalgatewayrouterip

set protocols bgp 65000
set protocols bgp 65000 neighbor 172.27.11.2 remote-as '65003'
set protocols bgp 65000 neighbor 172.27.11.2 update-source '172.27.11.1'
set protocols bgp 65000 network 172.27.11.0/24

set protocols bgp 65000 neighbor 172.27.12.2 remote-as '65003'
set protocols bgp 65000 neighbor 172.27.12.2 update-source '172.27.12.1'
set protocols bgp 65000 network 172.27.12.0/24

set protocols bgp 65000 neighbor 172.27.11.3 remote-as '65003'
set protocols bgp 65000 neighbor 172.27.11.3 update-source '172.27.11.1'

set protocols bgp 65000 neighbor 172.27.12.3 remote-as '65003'
set protocols bgp 65000 neighbor 172.27.12.3 update-source '172.27.12.1'

set protocols bgp 65000 redistribute connected
set protocols bgp 65000 parameters router-id '172.27.11.1'

set system ntp server 172.168.1.247

set system name-server 10.0.0.150
set system domain-search domain vcf.sddc.lab
set service dns forwarding listen-on '10.0.0.150'
set service dns forwarding name-server '10.0.0.150'

My NSX-T edge config deployed in SDDC Manager via API

{
    "asn": 65003,
    "edgeAdminPassword": "VMware123!VMware123!",
    "edgeAuditPassword": "VMware123!VMware123!",
    "edgeRootPassword": "VMware123!VMware123!",
    "mtu": 8940,
    "tier0Name": "VLC-Tier-0",
    "tier0RoutingType": "EBGP",
    "tier0ServicesHighAvailability": "ACTIVE_ACTIVE",
    "tier1Name": "VLC-Tier-1",
    "edgeClusterName": "EC-01",
    "edgeClusterProfileType": "DEFAULT",
    "edgeClusterType": "NSX-T",
    "edgeFormFactor": "LARGE",
    "edgeNodeSpecs": [ {
        "clusterId": "",
        "edgeNodeName": "edge1-mgmt.vcf.sddc.lab",
        "edgeTep1IP": "172.27.13.2/24",
        "edgeTep2IP": "172.27.13.3/24",
        "edgeTepGateway": "172.27.13.1",
        "edgeTepVlan": 13,
        "interRackCluster": false,
        "managementGateway": "10.0.0.1",
        "managementIP": "10.0.0.23/24",
        "uplinkNetwork": [ {
            "asnPeer": 65000,
            "bgpPeerPassword": "",
            "peerIP": "172.27.11.1/24",
            "uplinkInterfaceIP": "172.27.11.2/24",
            "uplinkVlan": 11
        },{
            "asnPeer": 65000,
            "bgpPeerPassword": "",
            "peerIP": "172.27.12.1/24",
            "uplinkInterfaceIP": "172.27.12.2/24",
            "uplinkVlan": 12
        } ]
    },{
        "clusterId": "",
        "edgeNodeName": "edge2-mgmt.vcf.sddc.lab",
        "edgeTep1IP": "172.27.13.4/24",
        "edgeTep2IP": "172.27.13.5/24",
        "edgeTepGateway": "172.27.13.1",
        "edgeTepVlan": 13,
        "interRackCluster": false,
        "managementGateway": "10.0.0.1",
        "managementIP": "10.0.0.24/24",
        "uplinkNetwork": [ {
            "asnPeer": 65000,
            "bgpPeerPassword": "",
            "peerIP": "172.27.11.1/24",
            "uplinkInterfaceIP": "172.27.11.3/24",
            "uplinkVlan": 11
        },{
            "asnPeer": 65000,
            "bgpPeerPassword": "",
            "peerIP": "172.27.12.1/24",
            "uplinkInterfaceIP": "172.27.12.3/24",
            "uplinkVlan": 12
        } ]
    } ]
}

My avn config deployed in SDDC Manager via API

{
    "avns": [ {
        "gateway": "10.50.0.1",
        "mtu": 8940,
        "name": "region-seg01",
        "regionType": "REGION_A",
        "routerName": "VLC-Tier-1",
        "subnet": "10.50.0.0",
        "subnetMask": "255.255.255.0"
    }, {
        "gateway": "10.60.0.1",
        "mtu": 8940,
        "name": "xregion-seg01",
        "regionType": "X_REGION",
        "routerName": "VLC-Tier-1",
        "subnet": "10.60.0.0",
        "subnetMask": "255.255.255.0"
    }],
    "edgeClusterId": ""
}

I hope this helps you with your vyos config for vlc vcf.

By Kader